EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел.

Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

—  каждое число в строке встречается по одному разу,

—  утроенная сумма максимального и минимального значений не превышает удвоенной суммы оставшихся чисел.

В ответе запишите только число.

Download File 1

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

f = open("embed.csv")
a = [list(map(int, line.split(","))) for line in f]

cnt = 0
for m in a:
    if any(m.count(el) > 1 for el in m):
        continue
    mx, mi = max(m), min(m)
    if (mx + mi) * 3 <= (sum(m) - mx - mi) * 2:
        cnt += 1
print(cnt) # 853

Ответ: 853

Автор - rubygem17

Объяснение

None

Назад