EGEsoll - сборник решений задач из ЕГЭ

Задача 8

В каждой строке электронной таблицы записаны шесть натуральных чисел.

Определите, сколько в таблице строк, для которых выполнены следующие условия:

—  в строке есть как повторяющиеся, так и неповторяющиеся числа;

—  среднее арифметическое всех неповторяющихся чисел строки больше, чем среднее арифметическое всех повторяющихся чисел этой строки.

При вычислении средних значений каждое число учитывается столько раз, сколько оно встречается в строке.

В ответе запишите число  — количество строк, для которых выполнены эти условия.

Download File 1

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Решение на Python:

a = [list(map(int, l.split(","))) for l in open("embed.csv")]
k = 0
for m in a:
    povt = [el for el in m if m.count(el) > 1]
    ne_povt = [el for el in m if m.count(el) == 1]
    if povt and ne_povt and sum(ne_povt) / len(ne_povt) > sum(povt) / len(povt):
        k += 1
print(k) # 2102

Ответ: 2102

Автор - rubygem17

Объяснение

None

Назад