EGEsoll - сборник решений задач из ЕГЭ

Задача 7

Откройте файл электронной таблицы, содержащей в каждой строке шесть натуральных чисел.

Download File 1

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

f = open("9.csv")
a = [list(map(int, line.split(","))) for line in f]

for m in a:
    nechet = [x for x in m if x % 2 != 0]
    chet = [x for x in m if x % 2 == 0]
    print(m, sorted(m))
    if m == sorted(m) and len(nechet) == len(chet):
        print(sum(m)) # 855
        break

Ответ: 855

Автор - rubygem17

Объяснение

None

Назад