EGEsoll - сборник решений задач из ЕГЭ

Задача 6

В каждой строке электронной таблицы записаны восемь натуральных чисел.

Число в строке считается заметным, если оно строго больше среднего арифметического всех чисел строки.

Определите количество строк таблицы, для которых одновременно выполнены следующие условия:

- количество заметных чётных чисел в строке больше количества заметных нечётных чисел в строке;

- сумма всех чётных чисел строки меньше суммы всех нечётных чисел строки.

Download File 1

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

f = open("9.csv")
a = []
for line in f.readlines():
    a.append(list(map(int, line.split(","))))

cnt = 0
for m in a:
    sa = sum(m) / len(m)
    zam = [el for el in m if el > sa]
    us1 = len([x for x in zam if x % 2 == 0]) > len([x for x in zam if x % 2 != 0])
    us2 = sum([x for x in m if x % 2 == 0]) < sum([el for el in m if el % 2 != 0])

    if us1 and us2:
        cnt += 1
print(cnt)  # 232

Ответ: 232

Автор - rubygem17

Объяснение

None

Назад