EGEsoll - сборник решений задач из ЕГЭ

Задача 5 досрок

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, для чисел которых выполнены оба условия:

– наибольшее число строки меньше суммы трёх других;

– четыре числа нельзя разбирать на две пары с равными суммами.

В ответе запишите только число.

Досрочный вариант 2026 - КЕГЭ

Download File 1

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Решение на Python:

k = 0
with open("9.csv") as f:
    for line in f:
        m = list(map(int, line.strip().split(",")))
        if max(m) >= sum(m) - max(m):
            continue
        if (
            (m[0] + m[1] == m[2] + m[3])
            or (m[0] + m[2] == m[1] + m[3])
            or (m[0] + m[3] == m[1] + m[2])
        ):
            continue
        k += 1
print(k) # 2500

ОтветЖ 2500

Автор - rubygem17

Объяснение

None

Назад