EGEsoll - сборник решений задач из ЕГЭ

Задача 4

Откройте файл электронной таблицы, содержащей в каждой строке восемь натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

— в строке минимальное число встречается два или три раза, остальные числа без повторений;

— сумма квадратов минимального и максимального из неповторяющихся чисел не больше квадрата суммы других неповторяющихся.

В ответе запишите только число.

Download File 1

Добавлено: 10.04.26 19:30

Перейти к решению

Решение

Решение на Python:

f = open("embed.csv")
a = []
for line in f.readlines():
    a.append(list(map(int, line.split(","))))
k = 0
for m in a:
    s = set(m)
    min_m = min(m)
    if (m.count(min_m) == 2 and len(s) == 7) or (m.count(min_m) == 3 and len(s) == 6):
        temp = m.copy()
        temp.remove(min_m)
        max_t = max(temp)
        min_t = min(temp)
        temp.remove(max_t)
        temp.remove(min_t)
        if (max_t**2 + min_t**2) <= sum(temp) ** 2:
            k += 1
print(k)  # 752

Ответ: 752

Автор - rubygem17

Объяснение

None

Назад