EGEsoll - сборник решений задач из ЕГЭ

Задача 3

В каждой строке электронной таблицы записаны четыре натуральных числа. Определите, сколько в таблице таких четвёрок, из которых можно выбрать три числа, которые не могут быть сторонами никакого треугольника, в том числе вырожденного (вырожденным называется треугольник, у которого сумма длин двух сторон равна длине третьей стороны).

Download File 1

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Приведём решение на Python:

f = open("9.csv")
a = []
for line in f.readlines():
    a.append(sorted(list(map(int, line.split(",")))))
k = 0
for m in a:
    if m[0] + m[1] < m[2] or m[0] + m[1] < m[3]:
        k += 1
print(k)  # 3094

Для решения на Python необходимо пересохранить .ods файл в .csv .

Ответ: 3094.

Автор - rubygem17

Объяснение

None

Назад