EGEsoll - сборник решений задач из ЕГЭ

Задача 2

Откройте файл электронной таблицы, содержащей в каждой строке шесть натуральных чисел. Определите количество строк таблицы, содержащих числа, для чисел которых выполнены оба условия:

- В строке есть ровно одно число, которое повторяется трижды, и остальные числа без повторений;

- Квадрат суммы всех повторяющихся чисел строки больше квадрата суммы всех неповторяющихся чисел строки.

В ответе запишите только число.

Download File 1

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

f = open("9.csv")
a = []
for line in f.readlines():
    a.append(list(map(int, line.split(","))))
f.close()
k = 0
for m in a:
    povt = 0
    f = False
    s = set(m)
    uniq = set(m)
    for el in m:
        if m.count(el) == 3:
            povt = el
            f = True
            break
    if not f:
        continue
    uniq.remove(povt)
    if len(s) == 4 and (3 * povt) ** 2 > sum(uniq) ** 2:
        k += 1
print(k)

Перед использованием кода нужно сохранить файл в формате .csv

Ответ: 40

Автор - rubygem17

Объяснение

None

Назад