EGEsoll - сборник решений задач из ЕГЭ

Задача 1

В каждой строке электронной таблицы записаны шесть натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых одновременно выполнены все следующие условия:

- Все числа в строке различны;

- Среднее арифметическое наибольшего и наименьшего чисел в строке больше среднего арифметического всех остальных чисел.

В ответе запишите число — количество строк, удовлетворяющих заданным условиям.

Download File 1

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Прежде чем решать это задание с помощью Python файл .ods надо пересохранить в формате .csv.

Это можно сделать через Файл -> Сохранить как -> Выбрать формат .csv

Приведём решение на Python:

f = open("converted.csv")

a = []

for line in f.readlines():
    a.append(list(map(int, line.split(","))))
k = 0
for m in a:
    if not all(m.count(m[i]) == 1 for i in range(len(m))):
        continue
    mx = max(m)
    mn = min(m)
    if (mx + mn) / 2 > (sum(m) - mx - mn) / 4:
        k += 1
print(k)
f.close()

Ответ: 6840

Автор - rubygem17

Объяснение

None

Назад