EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Сколько существует шестизначных чисел, делящихся на 5, в которых каждая цифра может встречаться только один раз, при этом никакие две чётные и две нечётные цифры не стоят рядом.

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

from itertools import product

cnt = 0
for p in product("0123456789", repeat=6):
    if p[-1] not in "05" or p[0] == "0":
        continue
    if any(p.count(el) > 1 for el in p):
        continue
    p = list(map(int, p))
    if all((p[i] % 2 == 0 and p[i+1] % 2 != 0) or (p[i] % 2 != 0 and p[i+1] % 2 == 0) for i in range(len(p)-1)):
        cnt += 1
print(cnt) # 1296

Ответ: 1296

Автор - rubygem17

Объяснение

None

Назад