EGEsoll - сборник решений задач из ЕГЭ

Задача 8

Иван составляет 5-⁠буквенные коды из букв И, В, А, Н. Буквы в коде могут повторяться, использовать все буквы не обязательно, но букву И нужно использовать хотя бы один раз. Сколько различных кодов может составить Иван?

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Решение на Python:

from itertools import product

k = 0
for p in product("ИВАН", repeat=5):
    if p.count("И") >= 1:
        k += 1
print(k) # 781

Ответ: 781

Автор - rubygem17

Объяснение

None

Назад