EGEsoll - сборник решений задач из ЕГЭ

Задача 7

Герасим составляет 7-⁠буквенные коды из букв Г, Е, Р, А, С, И, М. Каждую букву нужно использовать ровно 1 раз, при этом нельзя ставить подряд две гласные или две согласные. Сколько различных кодов может составить Герасим?

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

from itertools import product

k = 0
sog = "ГРСМ"
glas = "ЕАИ"
for p in product("ГЕРАСИМ", repeat=7):
    if any(p.count(c) > 1 for c in p):
        continue
    if any(
        (p[i] in sog and p[i+1] in sog) or (p[i] in glas and p[i+1] in glas)
        for i in range(len(p) - 1)
    ):
        continue
    k += 1
print(k) # 144

Ответ: 144

Автор - rubygem17

Объяснение

None

Назад