EGEsoll - сборник решений задач из ЕГЭ

Задача 6

Вася составляет 5-⁠буквенные слова, в которых есть только буквы С, Л, О, Н, причём буква С используется в каждом слове ровно 1 раз. Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

from itertools import product

k = 0
for p in product("СЛОН", repeat=5):
    if p.count("С") == 1:
        k += 1
print(k) # 405

Ответ: 405

Автор - rubygem17

Объяснение

None

Назад