EGEsoll - сборник решений задач из ЕГЭ

Задача 5 досрок

Все 5-буквенные слова, составленные из букв А, П, Р, Е, Л, Ь, записаны в алфавитном порядке и пронумерованы.

Определите, под каким номером в списке идёт последнее слово с чётным номером, которое не начинается с букв Ь или Р и при этом содержит в своей записи не менее двух букв Л.

Досрочный вариант 2026 - КЕГЭ

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Решение на Python:

from itertools import product

last_num = 0
for i, p in enumerate(product("АЕЛПРЬ", repeat=5), 1):
    if i % 2 != 0:
        continue
    if p[0] in "ЬР":
        continue
    if p.count("Л") < 2:
        continue

    last_num = i
print(last_num)  # 5058

Ответ: 5058

Автор - rubygem17

Объяснение

None

Назад