EGEsoll - сборник решений задач из ЕГЭ

Задача 3

Шифр кодового замка представляет собой последовательность из пяти символов, каждый из которых является цифрой от 1 до 4. Сколько различных вариантов шифра можно задать, если известно, что цифра 1 встречается ровно два раза, а каждая из других допустимых цифр может встречаться в шифре любое количество раз или не встречаться совсем?

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Приведём решение на Python:

from itertools import product

k = 0
for p in product("1234", repeat=5):
    if p.count("1") == 2:
        k += 1
print(k) # 270

Ответ: 270

Автор - rubygem17

Объяснение

None

Назад