EGEsoll - сборник решений задач из ЕГЭ

Задача 1

Ольга составляет 5-буквенные коды из букв О, Л, Ь, Г, А. Каждую букву нужно использовать ровно 1 раз, при этом Ь нельзя ставить первым и нельзя ставить после гласной. Сколько различных кодов может составить Ольга?

Источник: сдам ГИА: Решу ЕГЭ

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Приведём решение на Python:

from itertools import product

k = 0
for p in product(["О", "Л", "Ь", "Г", "А"], repeat=5):
    if not all([p.count(p[i]) == 1 for i in range(len(p))]):
        continue
    if p[0] == "Ь":
        continue
    vowels = "ОА"
    if all(
        [
            (p[i] in vowels and p[i + 1] != "Ь") or p[i] not in vowels
            for i in range(len(p) - 1)
        ]
    ):
        k += 1
print(k)

Ответ: 48

Автор - rubygem17

Объяснение

None

Назад