EGEsoll - сборник решений задач из ЕГЭ

Задача 7

Автомат получает на вход четырёхзначное число (число не может начинаться с нуля). По этому числу строится новое число по следующим правилам.

1. Складываются отдельно первая и вторая, вторая и третья, третья и четвёртая цифры заданного числа.

2. Наименьшая из полученных трёх сумм удаляется.

3. Оставшиеся две суммы записываются друг за другом в порядке неубывания без разделителей.

Пример. Исходное число: 1984. Суммы: 1+9 = 10, 9+8 = 17, 8+4 = 12. Удаляется 10. Результат: 1217.

Укажите наименьшее число, при обработке которого автомат выдаёт результат 613.

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

psbl = []
for n in range(1000, 10000):
    proc = []
    proc.append(int(str(n)[0]) + int(str(n)[1]))
    proc.append(int(str(n)[1]) + int(str(n)[2]))
    proc.append(int(str(n)[2]) + int(str(n)[3]))
    res = int("".join(map(str, sorted(proc, reverse=True)[:2][::-1])))
    if res == 613:
        psbl.append(n)
print(min(psbl))  # 1067

Ответ: 1067

Автор - rubygem17

Объяснение

None

Назад