EGEsoll - сборник решений задач из ЕГЭ

Задача 6 досрок

<p>

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.<br>1. Строится двоичная запись числа N.<br>2. К этой записи дописываются справа ещё два разряда по следующему правилу:<br>а) складываются все цифры двоичной записи, и остаток от деления суммы на 2 дописывается в конец числа (справа).&nbsp;Например, запись 11100 преобразуется в запись 111001;<br>б) над этой записью производятся те же действия – справа дописывается остаток от деления суммы цифр на 2.<br>Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной&nbsp;записью искомого числа R.<br>3. Результат переводится в десятичную систему и выводится на экран.<br>Например, для исходного числа 12<sub>10</sub> = 1100<sub>2 </sub>результатом является число 110000<sub>2</sub> = 48<sub>10</sub>, а для исходного числа 7<sub>10</sub> = 111<sub>2</sub> это число 11110<sub>2</sub> = 30<sub>10</sub>.<br>Укажите такое наименьшее число N, для которого результат работы алгоритма больше числа 253.<br>В ответе запишите это число в десятичной системе счисления.

</p>

<p>Досрочный вариант 2026 - КЕГЭ</p>

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Решение на Python:

psbl = []
for n in range(1, 10000):
    n2 = bin(n)[2:]
    n2 += str(n2.count("1") % 2)
    n2 += str(n2.count("1") % 2)
    if int(n2, 2) > 253:
        psbl.append(n)
print(min(psbl)) # 64

Автор - rubygem17

Объяснение

None

Назад