EGEsoll - сборник решений задач из ЕГЭ

Задача 5

Автомат получает на вход четырёхзначное число (число не может начинаться с нуля). По этому числу строится новое число по следующим правилам.

1. Складываются отдельно первая и вторая, вторая и третья, третья и четвёртая цифры заданного числа.

2. Наименьшая из полученных трёх сумм удаляется.

3. Оставшиеся две суммы записываются друг за другом в порядке неубывания без разделителей.

Пример. Исходное число: 1984. Суммы: 1+9 = 10, 9+8 = 17, 8+4 = 12. Удаляется 10. Результат: 1217.

Укажите наибольшее число, при обработке которого автомат выдаёт результат 613.

Добавлено: 10.04.26 19:30

Перейти к решению

Решение

Решение на Python:

for n in range(1000, 10000):
    r = []
    r.append(int(str(n)[0]) + int(str(n)[1]))
    r.append(int(str(n)[1]) + int(str(n)[2]))
    r.append(int(str(n)[2]) + int(str(n)[3]))
    r.sort(reverse=True)
    r.pop()
    t = "".join(list(map(str, r[::-1])))
    if int(t) == 613:
        print(n)

Ответ: 9424

Автор - rubygem17

Объяснение

None

Назад