EGEsoll - сборник решений задач из ЕГЭ

Задача 4

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

1. Строится двоичная запись числа N.

2. К этой записи дописываются справа ещё два разряда по следующему правилу:

а) складываются все цифры двоичной записи числа N, и остаток от деления суммы на 2 дописывается в конец числа (справа). Например, запись 11100 преобразуется в запись 111001;

б) над этой записью производятся те же действия — справа дописывается остаток от деления суммы цифр на 2.

Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной записью результирующего числа R.

Укажите такое наименьшее число N, для которого результат работы алгоритма больше числа 77. В ответе это число запишите в десятичной системе счисления.

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Приведём решение на Python:

for n in range(1, 100000):
    r = bin(n)[2:]
    d1 = sum(list(map(int, list(r)))) % 2
    r += str(d1)
    d2 = sum(list(map(int, list(r)))) % 2
    r += str(d2)
    if int(r, 2) > 77:
        print(n)  # 19
        break

Ответ: 19

Автор - rubygem17

Объяснение

None

Назад