EGEsoll - сборник решений задач из ЕГЭ

Задача 7 пара чисел

Дана последовательность N целых положительных чисел. Рассматриваются все пары элементов последовательности, разность которых чётна, и в этих парах, по крайней мере, одно из чисел пары делится на 17. Порядок элементов в паре неважен. Среди всех таких пар нужно найти и вывести пару с максимальной суммой элементов. Если одинаковую максимальную сумму имеет несколько пар, можно вывести любую из них. Если подходящих пар в последовательности нет, нужно вывести два нуля.

В ответе укажите два числа: значение искомой пары для файла.

Download File 1

Добавлено: 27.04.26 16:11

Перейти к решению

Решение

Решение на Python:

f = open("27991_B.txt")
n = f.readline()
a = [int(line) for line in f]

pari = []
for i in range(len(a)-1):
    for j in range(i+1, len(a)):
        if (a[i] % 17 == 0 or a[j] % 17 == 0) and (a[i] - a[j]) % 2 == 0:
            pari.append((a[i], a[j]))

print(sorted(pari, key=lambda x: x[0]+x[1])[-1]) # 10000 9996

Ответ: 10000, 9996

Автор - rubygem17

Объяснение

None

Назад