EGEsoll - сборник решений задач из ЕГЭ

Задача 5 егкр кластеризация

№ 28946 ЕГКР 18.04.26 (Уровень: Базовый)

Фрагмент звёздного неба спроецирован на плоскость с декартовой системой координат. Учёный решил провести кластеризацию полученных точек, являющихся изображениями звёзд, то есть разбить их множество на N непересекающихся непустых подмножеств (кластеров), таких что точки каждого подмножества лежат внутри прямоугольника со сторонами длиной H и W, причём эти прямоугольники между собой не пересекаются. Стороны прямоугольников не обязательно параллельны координатным осям.

Гарантируется, что такое разбиение существует и единственно для заданных размеров прямоугольников.

Будем называть центром кластера точку этого кластера, сумма расстояний от которой до всех остальных точек кластера минимальна. Для каждого кластера гарантируется единственность его центра. Расстояние между двумя точками на плоскости A(x1,y1) и B(x2,y2) вычисляется по формуле: d(A,B)=(x2?x1)2+(y2?y1)2

В файле A хранятся данные о звёздах двух кластеров, где H=6,5, W=4,5 для каждого кластера. В каждой строке записана информация о расположении на карте одной звезды: сначала координата x, затем координата y. Значения даны в условных единицах. Известно, что количество звёзд не превышает 1000.

В файле B хранятся данные о звёздах трёх кластеров, где H=6,5, W=5 для каждого кластера. Известно, что количество звёзд не превышает 10 000. Структура хранения информации о звездах в файле B аналогична файлу А.

Для файла А определите координаты центра каждого кластера, затем найдите два числа: А1 - в кластере с наибольшим количеством точек число точек, ордината которых меньше ординаты центра этого кластера, и А2 - расстояние по оси абсцисс между центрами кластеров.

Для файла Б определите координаты центра каждого кластера, затем найдите два числа: В1- число точек наименьшего по количеству точек кластера, находящихся внутри квадрата с центром в центре этого же кластера, сторонами, параллельными координатным осям, и длиной 1,8, и В2 - расстояние по оси ординат между центрами кластеров со наибольшим и средним количеством точек.

Гарантируется, что во всех кластерах количество точек различно.

В ответе запишите четыре числа: в первой строке - сначала A1, затем целую часть произведения A2 * 10 000; во второй строке - сначала B1, затем целую часть произведения B2 * 10 000.

Download File 1

Добавлено: 27.04.26 16:11

Перейти к решению

Решение

Решение на языке Python:

from math import dist

s = open("embed.txt")
data = []
for line in s:
    data.append([float(x) for x in line.split()])
print(len(data))


def get_cl(p0):
    cl = [p for p in data if dist(p, p0) < 1]
    if cl:
        for p in cl:
            data.remove(p)
        next_cl = [get_cl(p) for p in cl]
        cl += sum(next_cl, [])
    return cl


clusters = []
while data:
    cl = get_cl(data[0])
    print(len(cl))
    clusters.append(cl)


def centroid(cl):
    m = []
    for p in cl:
        sm = sum([dist(p, p0) for p0 in cl])
        m.append([sm, p])
    return min(m)[1]


centroids = [centroid(cl) for cl in clusters]
b2 = int(abs(abs(centroids[0][1]) - abs(centroids[1][1])) * 10000)
b1 = len([p for p in clusters[-1] if abs(abs(p[1]) - abs(centroids[-1][1])) < 1.8/2 and abs(abs(p[0]) - abs(centroids[-1][0])) < 1.8/2])
print(b1, b2)

Ответ: 89 107171

Автор - IdealniyAriets

Объяснение

None

Назад