EGEsoll - сборник решений задач из ЕГЭ

Задача 2 произведение кратно 14

Последовательность натуральных чисел характеризуется числом Х  — наибольшим числом, кратным 14 и являющимся произведением двух элементов последовательности с различными номерами. Гарантируется, что хотя бы одно такое произведение в последовательности есть.

В ответе укажите значение искомого произведения.

Download File 1

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Ответ: 994000

Оптимальное решение на Python:

f = open("embed.txt")
N = f.readline()

a = []
b = []
mch = 0
for line in f.readlines():

    if int(line) % 14 == 0:
        a.append(int(line))
    if int(line) > mch:
        mch = int(line)
    
    if int(line) % 7 == 0:
        a.append(int(line))
    if int(line) % 2 == 0:
        b.append(int(line))

print(max(a) * mch, max(a) * max(b)) # 994000 994000

Решение полным перебором на Python:

f = open("embed.txt")
N = f.readline()

a = [int(line) for line in f.readlines()]

lx = 0
for i in range(len(a)-1):
    for j in range(i+1, len(a)):
        if (a[i] * a[j]) % 14 == 0 and (a[i] * a[j]) > lx:
            lx = a[i] * a[j]
print("A:", lx)

Автор - rubygem17

Объяснение

None

Назад