EGEsoll - сборник решений задач из ЕГЭ

Задача 5 матрица

При проведении эксперимента заряженные частицы попадают на чувствительный экран, представляющий из себя матрицу размером 10.000.на 10.000 точек. При попадании каждой частицы на экран в протоколе фиксируются координаты попадания: номер ряда (целое число от 1 до 10.000) и номер позиции в ряду (целое число от 1 до 10.000).

Точка экрана, в которую попала хотя бы одна частица, считается светлой, точка, в которую ни одна частица не попала, — тёмной.

При анализе результатов эксперимента рассматривают группы светлых точек, расположенных в одном ряду подряд, то есть без тёмных точек между ними.

Вам необходимо по заданному протоколу определить максимальную длину такой группы и номер ряда, в котором эта группа встречается. Если таких рядов несколько, укажите минимально возможный номер.

Входные данные.

Первая строка входного файла содержит целое число N — общее количество частиц, попавших на экран. Каждая из следующих N строк содержит 2 целых числа: номер ряда и номер позиции в ряду.

В ответе запишите два целых числа: сначала максимальную длину непрерывной группы светлых точек, затем — номер ряда, в котором эта группа встречается.

Download File 1

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Приведём решение на Python:

f = open("26_1.txt")
N = f.readline()

a = []
for line in f.readlines():
    a.append(list(map(int, line.split())))

a = sorted(a, key=lambda item: item[0] * 1_000_000_000 + item[1])
k = 1
for i in range(len(a) - 1):
    if a[i][1] == a[i + 1][1]:
        continue
    if a[i][1] + 1 == a[i + 1][1] and a[i][0] == a[i + 1][0]:
        k += 1
    elif k > 1:
        print(k, a[i][0])
        k = 1

Программа выведет много значений. Необходимо вручную найти максимальное.

Ответ: 10 2786

Автор - rubygem17

Объяснение

None

Назад