EGEsoll - сборник решений задач из ЕГЭ

Задача 2 администратор

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя.

По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите максимальное число пользователей, чьи файлы можно сохранить в архиве, а также максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Входные данные.

В первой строке входного файла находятся два числа: S — размер свободного места на диске (натуральное число, не превышающее 10 000) и N — количество пользователей (натуральное число, не превышающее 4000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

Запишите в ответе два числа: сначала наибольшее число пользователей, чьи файлы могут быть помещены в архив, затем максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Download File 1

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Приведём решение на Python

f = open("embed.txt")
S, N = map(int, f.readline().split())
print(S, N)

p = sorted([int(line) for line in f.readlines()])
ad = []
for el in p:
    if S - el >= 0:
        S -= el
        ad.append(el)
print(len(ad), ad[-1]) # 611 27
# print(S) # 0

Заметим, что в результате работы программы S = 0. Следовательно, мы не сможем поместить файл большего размера, чем у нас уже есть.

Ответ: 611 27

Автор - rubygem17

Объяснение

None

Назад