EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [110203; 110245], числа, имеющие ровно четыре различных чётных натуральных делителя (при этом количество нечётных делителей может быть любым). Для каждого найденного числа запишите эти четыре делителя в четыре соседних столбца на экране с новой строки. Делители в строке должны следовать в порядке возрастания.

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

from math import isqrt

for x in range(110203, 110245):
    gfact = set()
    root = isqrt(x)
    if x % 2 == 0:
        gfact.add(x)
    for k in range(2, root+1):
        if x % k == 0:
            if k % 2 == 0:
                gfact.add(k)
            if (x // k) % 2 == 0:
                gfact.add(x//k)
    if len(gfact) == 4:
        print(sorted(gfact))

Ответ:

[2, 4, 55102, 110204]
[2, 14, 15746, 110222]
[2, 6, 36742, 110226]
[2, 22, 10022, 110242]

Автор - rubygem17

Объяснение

None

Назад