EGEsoll - сборник решений задач из ЕГЭ

Задача 5

Найдите все натуральные числа, принадлежащие отрезку [101_000_000; 102_000_000], у которых ровно три различных чётных делителя (при этом количество нечётных делителей может быть любым). В ответе перечислите найденные числа в порядке возрастания.

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Приведём решение на Python:

from math import isqrt

for x in range(101000000, 102000000 + 1):
    if x % 2 == 0:
        cnt = 1
        for k in range(2, isqrt(x) + 1):
            if cnt > 3:
                break
            if x % k == 0:
                if k % 2 == 0:
                    cnt += 1
                if x // k % 2 == 0:
                    cnt += 1
                if k == x // k:
                    cnt -= 1
        if cnt == 3:
            print(x)

Ответ:

101075762
101417282
101588258
101645282

Автор - rubygem17

Объяснение

None

Назад