EGEsoll - сборник решений задач из ЕГЭ

Задача 4

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [125256;125330], числа, имеющие ровно шесть различных чётных натуральных делителей. Для каждого найденного числа запишите эти шесть делителей в шесть соседних столбцов на экране с новой строки. Делители в строке должны следовать в порядке возрастания.

Например, в диапазоне [2;48] ровно шесть чётных различных натуральных делителей имеют числа 24, 36 и 40, поэтому для этого диапазона вывод на экране должна содержать следующие значения:

2 4 6 8 12 24

2 4 6 12 18 36

2 4 8 10 20 40

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

from math import isqrt

for x in range(125256, 125331):
    d = []
    root = isqrt(x)
    for k in range(1, root + 1):
        if x % k == 0:
            if k % 2 == 0:
                d.append(k)
            if x // k % 2 == 0:
                d.append(x // k)
    if len(d) == 6:
        d.sort()
        print(d)

Результат программы

[2, 6, 18, 13918, 41754, 125262]
[2, 4, 8, 31322, 62644, 125288]
[2, 6, 18, 13922, 41766, 125298]

и есть ответ.

Автор - rubygem17

Объяснение

None

Назад