EGEsoll - сборник решений задач из ЕГЭ

Задача 3

Напишите программу, которая перебирает целые числа, большие 5 000 000, в порядке возрастания и ищет среди них числа, представимые в виде произведения ровно трёх простых множителей, необязательно различных, каждый из которых содержит в своей записи хотя бы одну цифру 2 или 3. В ответе запишите первые пять чисел в порядке возрастания.

Добавлено: 23.03.26 18:57

Перейти к решению

Решение

Приведём решение на языке Python:

n = 5_000_001
k = 0
while k != 5:
    temp = n
    d = 2
    f = []
    while temp > 1:
        while temp % d == 0:
            f.append(d)
            temp //= d
        d += 1

    if len(f) == 3 and all([str(el).count("2") + str(el).count("3") > 0 for el in f]):
        print(n)
        k += 1
    n += 1

Ответ: 5000012 5000036 5000042 5000043 5000082

Автор - rubygem17

Объяснение

None

Назад