EGEsoll - сборник решений задач из ЕГЭ

Задача 11

Найдите все натуральные числа N, принадлежащие отрезку [200 000 000; 400 000 000], которые можно представить в виде N  =  2**m · 3**n, где m  — чётное число, n  — нечётное число. В ответе запишите все найденные числа в порядке возрастания.

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

for m in range(0, 31, 2):
    for n in range(1, 19, 2):
        if(200000000 <= 2 ** m * 3 ** n <= 400000000):
            print(2 ** m * 3 ** n)

Ответ:

229582512
322486272
254803968
201326592

Автор - rubygem17

Объяснение

None

Назад