EGEsoll - сборник решений задач из ЕГЭ

Задача 10

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [84052; 84130], число, имеющее максимальное количество различных натуральных делителей, если таких чисел несколько  — найдите минимальное из них. Выведите на экран количество делителей такого числа и само число.

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Решение на Python:

from math import isqrt
chisla = {}
for x in range(84052, 84131):
    fact = [1, x]
    root = isqrt(x)
    for k in range(2, root+1):
        if x % k == 0:
            fact.append(k)
            fact.append(x // k)
    chisla[len(fact)] = x
print(sorted(chisla))
print([(y, chisla[y]) for y in chisla if y == 72]) # 72, 84084

Ответ: 72, 84084

Автор - rubygem17

Объяснение

None

Назад