EGEsoll - сборник решений задач из ЕГЭ

Задача 1

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [568023;569230], число, имеющее максимальное количество различных натуральных делителей, если таких чисел несколько  — найдите минимальное из них. Выведите на экран количество делителей такого числа и само число.

Например, в диапазоне [2;48] максимальное количество различных натуральных делителей имеет число 48, поэтому для этого диапазона вывод на экране должн содержать следующие значения:

10 48

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Приведём решение на Python:

md = 0
ch = 0
for x in range(568023, 569231):
    d = set()
    d.update({1, x})
    root = int(x**0.5)
    if root * root == x:
        d.add(x**0.5)
    for k in range(2, root):
        if x % k == 0:
            d.update({k, x // k})
    if len(d) > md:
        md = len(d)
        ch = x
print(md, ch)  # 144 568260

Ответ: 144 568260

Автор - rubygem17

Объяснение

None

Назад