EGEsoll - сборник решений задач из ЕГЭ

Задача 6

Текстовый файл содержит только заглавные буквы латинского алфавита (ABC…Z). Определите максимальное количество идущих подряд символов, среди которых не более одной буквы A.

Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.

Download File 1

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

st = open("embed.txt").readline()
ans = 0
subs = st.split("A")
for i in range(len(subs) - 1):
    ans = max(len(subs[i]) + len(subs[i + 1]) + 1, ans)
print(ans)  # 337

Ответ: 337

Автор - rubygem17

Объяснение

None

Назад