EGEsoll - сборник решений задач из ЕГЭ

Задача 4

Текстовый файл содержит строки различной длины. Общий объём файла не превышает 1 Мбайт. Строки содержат только заглавные буквы латинского алфавита (ABC…Z).

В строках, содержащих менее 25 букв A, нужно определить и вывести максимальное расстояние между одинаковыми буквами в одной строке.

Download File 1

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Решение на Python:

f = open("embed.txt")
mxd = 0
for j in f.readlines():
    for i in "ABCDEFGHIJKLMNOPQRSTUVWXYZ":
        if j.rfind(i) - j.find(i) > mxd and j.count("A") < 25:
            mxd = j.rfind(i) - j.find(i)
print(mxd)  # 1004

Ответ: 1004

Автор - rubygem17

Объяснение

None

Назад