EGEsoll - сборник решений задач из ЕГЭ

Задача 3

Текстовый файл содержит только заглавные буквы латинского алфавита (ABC…Z). Определите символ, который чаще всего встречается в файле сразу после буквы A.

Например, в тексте ABCAABADDD после буквы A два раза стоит B, по одному разу — A и D. Для этого текста ответом будет B.

Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.

Download File 1

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

with open("embed.txt") as f:
    s = f.readline()

m = s.split("A")
d = {}
for sub in m:
    if len(sub) == 0:
        continue
    if sub[0] in d.keys():
        d[sub[0]] += 1
    else:
        d[sub[0]] = 1
print({k: v for k, v in sorted(d.items(), key=lambda item: item[1])})

Ответ: G

Автор - rubygem17

Объяснение

None

Назад