EGEsoll - сборник решений задач из ЕГЭ

Задача 1

Текстовый файл содержит строки различной длины. Общий объём файла не превышает 1 Мбайт. Строки содержат только заглавные буквы латинского алфавита (ABC…Z). Определите количество строк, в которых буква E встречается чаще, чем буква A.

Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.

Download File 1

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Приведём решение на Python

f = open("embed.txt")
k = 0
for line in f.readlines():
    if line.count("E") > line.count("A"):
        k += 1
print(k)  # 467
f.close()

Ответ: 467

Автор - rubygem17

Объяснение

None

Назад