EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Исполнитель Фибо преобразует число на экране.

У исполнителя есть две команды, которым присвоены номера.

1.  Прибавить 1.

2.  Прибавить 2.

Первая команда увеличивает число на экране на 1, вторая увеличивает его на 2.

Программа для исполнителя Фибо  — это последовательность команд.

Сколько существует программ, которые преобразуют исходное число 2 в число 18 и при этом траектория вычислений содержит число 9 и не содержит числа 14?

Траектория вычислений  — это последовательность результатов выполнения всех команд программы. Например, для программы 212 при исходном числе 7 траектория будет состоять из чисел 9, 10, 12.

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Решение на Python:

def f(s, e):
    if s > e or s == 14:
        return 0
    if s == e:
        return 1
    return f(s+1, e) + f(s+2, e)
print(f(2,9)*f(9,18)) # 315

Автор - rubygem17

Объяснение

None

Назад