EGEsoll - сборник решений задач из ЕГЭ

Задача 5 досрок

Исполнитель преобразует число на экране. У исполнителя есть три команды, которые обозначены латинскими буквами:
A. Прибавить 1
B. Прибавить 3
C. Умножить на 2
Программа для исполнителя – это последовательность команд.
Сколько существует программ, для которых при исходном числе 2 результатом является число 25, и при этом траектория
вычислений содержит число 15 и не содержит 7?
Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы CBA при исходном числе 7 траектория состоит из чисел 14, 17, 18.

Досрочный вариант 2026 - КЕГЭ

Добавлено: 17.04.26 20:45

Перейти к решению

Решение

Решение на Python:

def f(s, e):
    if s > e or s == 7:
        return 0
    if s == e:
        return 1
    return f(s + 1, e) + f(s + 3, e) + f(s * 2, e)


print(f(2, 15) * f(15, 25))  # 2716

Ответ: 2716

Автор - Maxim

Объяснение

None

Назад