EGEsoll - сборник решений задач из ЕГЭ

Задача 1

Исполнитель РазДваТри преобразует число на экране.

У исполнителя есть три команды, которым присвоены номера.

1. Прибавить 1.

2. Умножить на 2.

3. Прибавить 3.

Первая команда увеличивает число на экране на 1, вторая умножает его на 2, третья увеличивает на 3.

Программа для исполнителя РазДваТри — это последовательность команд.

Сколько существует программ, которые преобразуют исходное число 3 в число 16 и при этом траектория вычислений не содержит чисел 6 и 12?

Траектория вычислений — это последовательность результатов выполнения всех команд программы. Например, для программы 312 при исходном числе 6 траектория будет состоять из чисел 9, 10, 20.

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Приведём решение на Python:

def f(s, e):
    if s == e:
        return 1
    if s > e or s == 6 or s == 12:
        return 0
    return f(s + 1, e) + f(s * 2, e) + f(s + 3, e)


print(f(3, 16))  # 22

Ответ: 22

Автор - rubygem17

Объяснение

None

Назад