EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Логическая функция F задаётся выражением ((x ∧ y) ∨ (y ∧ z)) ≡ ((x → w) ∧ (w → z)). Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F. Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z, w.

Пе­ре­мен­ная 1 Пе­ре­мен­ная 2 Пе­ре­мен­ная 3 Пе­ре­мен­ная 4 Функ­ция ??? ??? ??? ??? F 0 1 1 1 1 0 1 0 1 0 1 0 1

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

for x in range(2):
    for y in range(2):
        for z in range(2):
            for w in range(2):
                if ((x and y) or (y and z)) == ((x <= w) and (w <= z)):
                    print(x, w, z, y)

Ответ: xwzy

Автор - rubygem17

Объяснение

None

Назад