EGEsoll - сборник решений задач из ЕГЭ

Задача 8

Логическая функция F задаётся выражением (x ≡ ( w ∨ y)) ∨ ((w  → z ) ∧ (y  → w)). Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F. Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z, w.

Пе­ре­мен­ная 1 Пе­ре­мен­ная 2 Пе­ре­мен­ная 3 Пе­ре­мен­ная 4 Функ­ция ??? ??? ??? ??? F 1 1 0 1 0 1 1 0

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала  — буква, соответствующая первому столбцу; затем  — буква, соответствующая второму столбцу, и т. д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Программа на Python:

for x in range(2):
    for y in range(2):
        for w in range(2):
            for z in range(2):
                if (x == (w or y)) or ((w <= z) and (y <= w)):
                    pass
                else:
                    print(y,x,z,w, 0)

Ответ: yxzw

Автор - rubygem17

Объяснение

None

Назад