EGEsoll - сборник решений задач из ЕГЭ

Задача 7

Миша заполнял таблицу истинности функции (x ∧ ¬y) ∨ (x ≡ z) ∨ ¬w, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

(x ∧ ¬y) ∨ (xz) ∨ ¬w 0 1 1 0 0 0 0 1 0 1 0

Определите, какому столбцу таблицы истинности соответствует каждая из переменных w, x, y, z.

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

for x in range(2):
    for y in range(2):
        for z in range(2):
            for w in range(2):
                if not((x and not y) or (x == z) or not w):
                    print(x,w,z,y)

Ответ: xwzy

Автор - rubygem17

Объяснение

None

Назад