EGEsoll - сборник решений задач из ЕГЭ

Задача 6

Логическая функция F задаётся выражением ((x → y) ≡ (y → z)) ∧ (y ∨ w). Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F. Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z, w.

Пе­ре­мен­ная 1 Пе­ре­мен­ная 2 Пе­ре­мен­ная 3 Пе­ре­мен­ная 4 Функ­ция
??? ??? ??? ??? F
0 0 1
0 0 0 1
0 1

В ответе напишите буквы x, y, z, w в том порядке, в котором идут соответствующие им столбцы (сначала  — буква, соответствующая первому столбцу; затем  — буква, соответствующая второму столбцу, и т. д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Программа на Python:

for x in range(2):
    for y in range(2):
        for z in range(2):
            for w in range(2):
                if ((x <= y) == (y <= z)) and (y or w):
                    print(x, z, w, y)

Путём перестановки переменных, мы получим такой результат:

0 0 1 0 (2)
0 1 1 0 (3)
0 1 0 1 (1)
0 1 1 1
1 1 0 1
1 1 1 1

Ответ: xzwy

Автор - rubygem17

Объяснение

None

Назад