EGEsoll - сборник решений задач из ЕГЭ

Задача 4

Логическая функция F задаётся выражением (x ∧ ¬y) ∨ (y ≡ z) ∨ ¬w. На рисунке приведён фрагмент таблицы истинности функции F, содержащий все наборы аргументов, при которых функция F ложна. Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных w, x, y, z. Все строки в представленном фрагменте разные.

Перем. 1 Перем. 2 Перем. 3 Перем. 4
??? ??? ??? ???
0
1 0 0
1 0 0

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (без разделителей).

Добавлено: 10.04.26 19:30

Перейти к решению

Решение

Решение на Python:

for x in range(0, 2):
    for y in range(0, 2):
        for z in range(0, 2):
            for w in range(0, 2):
                if not ((x and not y) or (y == z) or not w):
                    print(w, z, y, x)
# 1 1 0 0
# 1 0 1 0
# 1 0 1 1

Ответ: wzyx

Автор - rubygem17

Объяснение

None

Назад