EGEsoll - сборник решений задач из ЕГЭ

Задача 3

Логическая функция F задаётся выражением (x ∨ y) → (z ≡ x). Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F. Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z.

Переменная 1 Переменная 2 Переменная 3 Функция
??? ??? ??? F
0 0 0
0 0

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Приведём решение на Python:

res = set()
for x in range(0, 2):
    for y in range(0, 2):
        for z in range(0, 2):
            if not ((x or y) <= (z == x)):
                res.add(f"{x}{z}{y}")
for l in res:
    print(l)

Вывод программы каждый раз будет различаться, потому что set - неупорядоченная коллекция.

Ответ: xzy

Автор - rubygem17

Объяснение

None

Назад