EGEsoll - сборник решений задач из ЕГЭ

Задача 2

Логическая функция F задаётся выражением ((y → z) ∨ (¬x ∧ w)) ≡ (w ≡ z). Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F. Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z, w.

Переменная 1 Переменная 2 Переменная 3 Переменная 4 Функция
??? ??? ??? ??? F
1 0 0 1
0 0 0 1 1
0 1 1

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

for y in range(0, 2):
    for z in range(0, 2):
        for x in range(0, 2):
            for w in range(0, 2):
                if ((y <= z) or (not x and w)) == (w == z):
                    print(z, w, y, x)

Результат кода:

0 0 0 0 - 1
0 0 0 1 - 3
1 1 0 0 - 2
1 1 0 1
0 1 1 1 - 4
1 1 1 0
1 1 1 1

Нас интересует только те, что приведены в таблице. Отметим их цифрами.

Автор - rubygem17

Объяснение

None

Назад