EGEsoll - сборник решений задач из ЕГЭ

Задача 1

Логическая функция F задаётся выражением ((x → y ) ∧ (y → w)) ∨ (z ≡ ( x ∨ y)). Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F. Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z, w.

Переменная 1 Переменная 2 Переменная 3 Переменная 4 Функция
??? ??? ??? ??? F
1 1 0
1 0
1 1 0
Источник

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Решение на языке Python:

for x in range(0, 2):
    for y in range(0, 2):
        for z in range(0, 2):
            for w in range(0, 2):
                if not (((x <= y) and (y <= w)) or (z == (x or y))):
                    print(y, w, z, x)

Найдём необходимые:

1 0 0 0
0 0 0 1
0 1 0 1
1 0 0 1

ПЕРВОАПРЕЛЬСКОЕ ОБНОВЛЕНИЕ!

Решение на C++

#include <cstdio>

void n2() {
  for (int x{0}; x < 2; x++) {
    for (int y{0}; y < 2; y++) {
      for (int z{0}; z < 2; z++) {
        for (int w{0}; w < 2; w++) {
          if (!((x <= y) and (y <= w)) or (z == (x || y))) {
            printf("%d %d %d %d\n", y, w, z, x);
          }
        }
      }
    }
  }
}

int main() {
  n2();
  return 0;
}

Найдём необходимые:

1 0 0 0
0 0 0 1
0 1 0 1
1 0 0 1

Ответ: ywzx

Автор - rubygem17

Объяснение

None

Назад