EGEsoll - сборник решений задач из ЕГЭ

Задача 9 - одна куча

Задание 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один камень или увеличить количество камней в куче в два раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

Игра завершается в тот момент, когда количество камней в куче становится не менее 29. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 29 или больше камней.

В начальный момент в куче было S камней, 1 ≤ S ≤ 28.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Задание 20

Найдите два таких значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

—  Петя не может выиграть за один ход;

—  Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Найденные значения запишите в ответе в порядке возрастания.

Задание 21

Для игры, описанной в задании 19, найдите значение S, при котором одновременно выполняются два условия:

—  у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

—  у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Если найдено несколько значений S, в ответе запишите минимальное из них.

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

def f(m, s):
    if s >= 29:
        return m % 2 == 0
    if m == 0:
        return 0
    h = [f(m-1, s+1), f(m-1, s*2)]
    return any(h) if m % 2 != 0 else all(h)

print("19:", [s for s in range(1, 29) if not f(1, s) and f(2, s)]) # 14
print("20:", [s for s in range(1, 29) if not f(1, s) and f(3, s)]) # 7 13
print("21:", [s for s in range(1, 29) if not f(2, s) and (f(2,s) or f(4, s))]) # 12

Ответ:

Задание 19: 14

Задание 20: 713

Задание 21: 12

Автор - rubygem17

Объяснение

None

Назад