EGEsoll - сборник решений задач из ЕГЭ

Задача 6 - одна куча уникальные ходы

Задание 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один камень, добавить два камня или увеличить количество камней в куче в два раза. При этом нельзя повторять ход, который только что сделал второй игрок.

Например, если в начале игры в куче 3 камня, Петя может первым ходом получить кучу из 4, 5 или 6 камней. Если Петя получил кучу из 5 камней (добавил 2 камня), то следующим ходом Ваня может получить 6 или 10 камней. Получить 7 камней Ваня не может, так как для этого нужно добавить 2 камня, а такой ход только что сделал Петя.

Чтобы делать ходы, у каждого игрока есть неограниченное количество камней. Игра завершается, когда количество камней в куче становится не менее 34. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 34 или больше камней. В начальный момент в куче было S камней, 1 ⩽ S ⩽ 33.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Задание 20

Существует несколько таких значений S, при которых у Пети есть выигрышная стратегия, причём Петя не может выиграть первым ходом, но может выиграть своим вторым ходом независимо от того, как будет ходить Ваня. Найдите наименьшее и наибольшее из таких значений S.

В ответе запишите сначала наименьшее, затем наибольшее значение.

Задание 21

Найдите значение S, при котором у Вани есть выигрышная стратегия, позволяющая ему выиграть вторым ходом при любой игре Пети, но у Вани нет стратегии, которая позволяла бы ему гарантированно выиграть первым ходом.

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

def f(m, s, y):
    if s >= 34:
        return m % 2 == 0
    if m == 0:
        return 0
    # переменная y отслеживает прошлое действие. Коды:
    # 1: s+1
    # 2: s+2
    # 3: s*2
    if y == 1:
        h = [f(m - 1, s + 2, 2), f(m - 1, s * 2, 3)]
    elif y == 2:
        h = [f(m - 1, s + 1, 1), f(m - 1, s * 2, 3)]
    elif y == 3:
        h = [f(m - 1, s + 1, 1), f(m - 1, s + 2, 2)]
    else:
        h = [f(m - 1, s + 1, 1), f(m - 1, s + 2, 2), f(m - 1, s * 2, 3)]
    return any(h) if m % 2 != 0 else all(h)


print("19:", [s for s in range(1, 34) if not f(1, s, 0) and f(2, s, 0)])  # 16
print("20:", [s for s in range(1, 34) if not f(1, s, 0) and f(3, s, 0)])  # 815
print("21:", [s for s in range(1, 34) if not f(2, s, 0) and f(4, s, 0)])  # 7

Ответы:

- 19: 16

- 20: 815

- 21: 7

Автор - rubygem17

Объяснение

None

Назад