EGEsoll - сборник решений задач из ЕГЭ

Задача 5 - досрок

19 задача

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) один камень или увеличить количество камней в куче в три раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней. 
Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 65. Победителем считается игрок, сделавший последний ход, т.е. первым получивший такую позицию, при которой в кучах оказывается 65 или больше камней. 
В начальный момент в первой куче было шесть камней, во второй куче – S камней; 1 ≤ S ≤ 58. 
Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. 
Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите минимальное значение S, при котором такая ситуация возможна.

Задание 20

Для игры, описанной в задании 19, найдите два наименьших значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия: 
– Петя не может выиграть за один ход; 
– Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня. 
Найденные значения запишите в ответе в порядке возрастания.

Задание 21

Для игры, описанной в задании 19, найдите минимальное значение S, при котором одновременно выполняются два условия: 
– у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети; 
– у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом. 
Если найдено несколько значений S, в ответе укажите наименьшее из них.

Досрочный вариант 2026 - КЕГЭ

Добавлено: 17.04.26 20:45

Перейти к решению

Решение

Решение на Python:

def f(m, s1, s2):
    if s1 + s2 >= 65:
        return m % 2 == 0
    if m == 0:
        return 0
    h = [
        f(m - 1, s1 + 1, s2),
        f(m - 1, s1, s2 + 1),
        f(m - 1, s1 * 3, s2),
        f(m - 1, s1, s2 * 3),
    ]
    # Для решения 19 меняем all(h) на any(h)
    return any(h) if m % 2 != 0 else all(h)


print("19:", [s for s in range(1, 59) if f(2, 6, s)])  # 7
print("20:", [s for s in range(1, 59) if not f(1, 6, s) and f(3, 6, s)])  # 10 19
print(
    "21:",
    [s for s in range(1, 29) if not f(2, 6, s) and (f(2, 6, s) or f(4, 6, s))],
)  # 18

Ответы:

- 19: 7

- 20: 10 19

- 21: 18

Автор - Maxim

Объяснение

None

Назад